Ferramentas do usuário

Ferramentas do site


configuracao_switch_hp

COMANDOS BÁSICOS SWITCHS HP

AO EFETUAR UMA CONFIGURAÇÃO E TER CERTEZA QUE ESTÁ CORRETA, NÃO SE ESQUEÇA DE APLICAR O COMANDO “save”

Entra no modo para configurações:

<HP>system-view

Verificar todas configurações do switch:

[SW-HP-REITORIA-COIMR-CORE]display current-configuration

Verificar as configurações de cada interface

[SW-HP-REITORIA-COIMR-CORE-Vlan-interface2]display this

Verificar apenas as configurações das interfaces

[SW-HP-REITORIA-COIMR-CORE]display interface brief

Verificar informações interface poe

[SW-HP-PRONATEC02]display poe interface

Dar um nome ao equipamento:

<HP>sysname SW-HP-REITORIA-CORE
[SW-HP-REITORIA-COIMR-CORE-vlan2]save

Criar vlans

[SW-HP-REITORIA-COIMR-CORE]vlan NÚMERO_DA_VLAN
[SW-HP-REITORIA-COIMR-CORE-vlan2]name NOME_DA_VLAN
[SW-HP-REITORIA-COIMR-CORE-vlan2]save
[SW-HP-REITORIA-COIMR-CORE-vlan2]quit

Habilita o dhcp snooping

OBS: O dhcp snooping classifica cada porta como trusted ou untrusted (confiável ou não confiável). Os servidores DHCP ficam nas portas trusted, e o restante das portas como untrusted, o switch intercepta todas as requisições DHCP nas portas untrusted antes de encaminhá-las, caso ele receba um DHCP Reply de uma porta não confiável, esse pacote será descartado.

[SW-HP-REITORIA-COIMR-CORE]dhcp-snooping
[SW-HP-REITORIA-COIMR-CORE]save

Proteção conta ataque de ARP Spoofing

[SW-HP-REITORIA-COIMR-CORE]arp detection validate ip
[SW-HP-REITORIA-COIMR-CORE]arp ip-conflict prompt
[SW-HP-REITORIA-COIMR-CORE]arp check enable
[SW-HP-REITORIA-COIMR-CORE]save

Resetar interface - Limpar configurações da porta:

[SW-HP-REITORIA-COIMR-CORE-GigabitEthernet1/0/11]default

Configurando as portas GigabitEthernet do switch

Para configurar várias portas, em sequência, de uma só vez, usar o comando abaixo para entrar nas interfaces:

[SW-HP-REITORIA-COIMR-CORE]interface range GigabitEthernet 1/0/1 to GigabitEthernet 1/0/X (X = Número da última porta da sequência)

Para configurar apenas uma porta do switch por vez, usar o comando abaixo para entrar na interface:

[SW-HP-REITORIA-COIMR-CORE]interface GigabitEthernet 1/0/X (X = Número da porta do switch)

Dentro da interface usar os comandos abaixo:

Configurando a Vlan na porta:

[SW-HP-REITORIA-COIMR-CORE-GigabitEthernet1/0/11]port access vlan Y (Y = Número da Vlan que se quer configurar na interface)

Habilitar o Spanning Tree BPDU no modo global:

[SW-HP-REITORIA-COIMR-CORE]stp bpdu-protection

Habilitar o Spanning-Tree na porta:

OBS:Para conexão com hosts usar o stp edged-port enable, Para conexão com switch usar o stp point-to-point force-true

[SW-HP-REITORIA-COIMR-CORE-GigabitEthernet1/0/11]stp edged-port enable
[SW-HP-REITORIA-COIMR-CORE-GigabitEthernet1/0/11]stp point-to-point force-true

Configura a porta como Root Guard:

[SW-HP-REITORIA-COIMR-CORE-GigabitEthernet1/0/11]stp root-protection

Habilitar o Power over Ethernet:

[SW-HP-REITORIA-COIMR-CORE-GigabitEthernet1/0/11]poe enable

Habilitar a Proteção de Acesso ao switch:

[SW-HP-REITORIA-COIMR-CORE-GigabitEthernet1/0/11]port-security max-mac-count 3

Criando Interfaces Aggregation: OBS:Apenas usar se precisar utilizar as portas GigabitEthernet para conexão entre switches.

[SW-HP-REITORIA-COIMR-CORE]interface Bridge-Aggregation (Z= n° da Interface aggregation)

Configurar interface como trunk:

[SW-HP-REITORIA-COIMR-CORE-GigabitEthernet1/0/11]port link-type trunk  

Configurar Vlans que terão acesso a porta tunk:

[SW-HP-REITORIA-COIMR-CORE-GigabitEthernet1/0/11]port trunk permit vlan 2,20,30,40

Configura a interface como confiável para não haver detecção de ARP:

[SW-HP-REITORIA-COIMR-CORE-GigabitEthernet1/0/11]arp detection trust

Habilita a porta como trusted (confiável) para o DHCP:

[SW-HP-REITORIA-COIMR-CORE-GigabitEthernet1/0/11]dhcp-snooping trust

Estabelecendo a conexão do Link-Aggregation utilizando o protocolo LACP:

link-aggregation mode dynamic

Logar nas interfaces que quer fazer aggregation:

[SW-HP-REITORIA-COIMR-CORE]interface range GigabitEthernet 1/0/x to GigabitEthernet 1/0/X  (X = Número da última porta da sequencia)   

Dentro da interface usar os comandos abaixo:

[SW-HP-REITORIA-COIMR-CORE-if-range]port link-aggregation group X (X = n° da Interface aggregation criada)

configura a interface como trunk:

[SW-HP-REITORIA-COIMR-CORE-if-range]port link-type trunk         

configurar as Vlans que terão acesso a porta tunk:

[SW-HP-REITORIA-COIMR-CORE-if-range]port trunk permit vlan 2,20,30,40

Habilitar o Spanning-Tree na porta:

[SW-HP-REITORIA-COIMR-CORE-if-range]stp point-to-point force-true

Configurar uma interface como confiável para não haver detecção de ARP:

[SW-HP-REITORIA-COIMR-CORE-if-range]arp detection trust

Habilita a porta como trusted (confiável) para o DHCP:

[SW-HP-REITORIA-COIMR-CORE-if-range]dhcp snooping trust

Estabelecendo a conexão do Link-Aggregation utilizando o protocolo LACP:

link-aggregation mode dynamic
save
quit

Comandos para Verificar se o link subiu

[SW-HP-REITORIA-COIMR-CORE]display link-aggregation verbose
[SW-HP-REITORIA-COIMR-CORE]display link-aggregation summary

Cria o scheme para autenticação:

[SW-HP-REITORIA-COIMR-CORE]local-user admin
[SW-HP-REITORIA-COIMR-CORE-luser-admin]password cipher SENHA         
[SW-HP-REITORIA-COIMR-CORE-luser-admin]service-type ssh terminal
[SW-HP-REITORIA-COIMR-CORE-luser-admin]authorization-attribute user-role network-admin
[SW-HP-REITORIA-COIMR-CORE-luser-admin]save
[SW-HP-REITORIA-COIMR-CORE-luser-admin]quit

Configurando as linhas VTY para acesso remoto via SSH:

Habilita o ssh:

[SW-HP-REITORIA-CORE]ssh server enable

Entra na interface VTY:

[SW-HP-REITORIA-COIMR-CORE]line VTY 0 63

Faz a autenticação no terminal SSH:

user-role network-admin
authentication-mode scheme          
save
quit

Configura a autenticação para a porta do console aux 0:

Entra na interface aux0:

[SW-HP-REITORIA-COIMR-CORE]line aux 0

Faz a autenticação no terminal console:

user-role network-admin
authentication-mode scheme        
save
quit

Configura a interface de rede do switch:

Cria a interface Vlan-interfaceX:

[SW-HP-REITORIA-COIMR-CORE]interface Vlan-interfaceX
[SW-HP-REITORIA-COIMR-CORE-Vlan-interface2]description XXXXXXXX

Dar ip estático ao switch:

[SW-HP-REITORIA-COIMR-CORE-Vlan-interface2] ip address (IP) (Mascara)       
[SW-HP-REITORIA-COIMR-CORE-Vlan-interface2]save
[SW-HP-REITORIA-COIMR-CORE-Vlan-interface2]quit

Cria rota para o switch core:

[SW-HP-REITORIA-COIMR-CORE]ip route-static 0.0.0.0 0 (IP do switch CORE)      
[SW-HP-REITORIA-COIMR-CORE]save
[SW-HP-REITORIA-COIMR-CORE]quit

Setar tensão na porta do switch

[SW-HP-REITORIA-COIMR-CORE-GigabitEthernet1/0/11]poe max-power 5000
[SW-HP-REITORIA-COIMR-CORE-GigabitEthernet1/0/11]poe priority high
[SW-HP-REITORIA-COIMR-CORE-GigabitEthernet1/0/11]save
[SW-HP-REITORIA-COIMR-CORE-GigabitEthernet1/0/11]quit

Limpar arquivos na lixeira

<SW-HP-CORE>dir /all
<SW-HP-CORE>reset recycle-bin

Ver Logs

[SW-HP-CORE]display log

Reiniciar switch

<SW-HP-COIMR-REITORIA-CORE>reboot
configuracao_switch_hp.txt · Última modificação: 05/11/2018 06:49:48 por Alex Oliveira Soares